pfSense 2.4 Bad Gateway in der webGUI

Nach dem Update auf pfSense 2.4 kann es zu einer Meldung 502 Bad Gateway in der Webgui bzw zu einer nicht nutzbaren Terminalsession via SSH kommen

Dieser Fehler wird durch das Paket pfblockerNG hervorgerufen.

pfblockerNG

pfBlockerNG ist ein Plugin, welches als Downloadmanager für Filterlisten fungiert. Mit Hilfe dieser Filterlisten und dem DNSresolve und DNScache unbound werden Werbung und Tracker auf Basis der DNSeinträge vorab gefiltert und so für den Client nicht mehr zugänglich gemacht.

Siehe hierzu easylist.to

Vorab Bugfix

Es wird folgender Fix nötig sein, falls das Paket in der Version 2.1.2 installiert und noch kein neues Paket seitens des Developers vorhanden ist

Via SSH an der Firewall anmelden.
Nach dem Erscheinen und dem stoppen der Ausgabe von

*** Welcome to pfSense 2.4.0-RELEASE (amd64) on $HOSTNAME ***

CTRL+Z drücken und folgendes in die Eingabeaufforderung kopieren:

fetch -o /usr/local/www/pfblockerng/www/index.php "https://gist.githubusercontent.com/BBcan177/9f9c8e62b166cee07ad16cd4ff59103c/raw"
fetch -o /usr/local/pkg/pfblockerng/pfblockerng.inc "https://gist.githubusercontent.com/BBcan177/7ff15715be0f02afdbe0a00c676aedce/raw"

 

via reboot die Firewall neu starten.

Der komplette Thread zu dem Thema.

Added some temp file removal to the patches. So please re-download this new code if you have downloaded these files prior to this post, please re-download the same URLs above to get the new changes…. Thanks!

A reboot is recommended following these patches.

Once the code has been tested, I will submit this as a PR.

Please report back your feedback.

Thanks!
BBcan177

pfSense 2.4 Bad Gateway in der webGUI
Markiert in:                 

5 Gedanken zu „pfSense 2.4 Bad Gateway in der webGUI

  • 2017-12-30 um 10:56
    Permalink

    Läuft danach die Firewall mit PfblockerNG stabil? Ich kämpfe schon seit Wochen mit diesem Bug und stehe kurz davor meinen Raspi oder einen eigen DNS Werbeblocker als Server aufzusetzen.
    Danke,

    Antworten
    • 2017-12-31 um 10:24
      Permalink

      Lief trifft es besser. Nun ist schon wieder der Wurm drinnen. Ich habe nun einen Reboot via cron in der Nacht gesetzt und kümmere mich nach den Feiertagen um das Problem. Nach dem Blogpost kam ein Update des Plugins und pfSense lief. Nun gab es wieder ein Update und alles ist beim alten und die funktional.

      Ich werde dies wahrscheinlich lösen indem ich das Plugin deinstalliere und ein Script unter pfSense nutzen werde. Dies werde ich dann im Blog veröffentlichen.

      Antworten
  • 2018-01-01 um 20:17
    Permalink

    Welches Script? Da meine pfsense unter proxmox läuft, hatte ich mir auch schon einen Reboot via cronjob überlegt. Aber das kann doch nicht die Lösung für eine professionelle Lösung sein…

    Antworten
    • 2018-01-02 um 11:58
      Permalink

      Zu dem letzteren Satz stimmt ich Dir vollkommen zu und muss zugeben, dass ich mich mehr als irritiert.
      Ich verfolge den Spaß nun schon länger und einer schiebt dem anderen den schwarzen Peter zu.

      Das mit dem Script hat die Bewandtnis, dass hier nur das Plugin als schöne GUI für eine Funktion genutzt wird, welches Du auf deinem RaspberryPI händisch machen möchtest, als Beispiel Pihole. Somit kannst Du Dir selbst ein Script schreiben, welche diese Funktion selbst auf der Kommandozeile darstellt.
      Plugin draußen, pfSense hat keine Probleme mehr. Schau hier einmal in das Forum zu dem Thema Bufferprobleme durch das Plugin.

      Schau mal hier zu dem Thema ein Artikel für OPNsense https://devinstechblog.com/block-ads-with-dns-in-opnsense/

      Antworten

Schreibe einen Kommentar

You have to agree to the comment policy.