Octopress rake generate lib.so cannot LoadError

Es gibt unter Octopress und auch Jekyll einen netten Fehler, wenn man versucht etwas durch das pygments plugin zu parsen

/home/chris/.rvm/gems/ruby-1.9.2-p318/gems/ffi-1.0.9/lib/ffi/library.rb:75:in `block in ffi_lib': Could not open library 'lib.so': lib.so: cannot open shared object file: No such file or directory (LoadError)
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/ffi-1.0.9/lib/ffi/library.rb:54:in `map'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/ffi-1.0.9/lib/ffi/library.rb:54:in `ffi_lib'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/rubypython-0.5.1/lib/rubypython/python.rb:29:in `'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/rubypython-0.5.1/lib/rubypython/python.rb:21:in `'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/rubypython-0.5.1/lib/rubypython.rb:261:in `load'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/rubypython-0.5.1/lib/rubypython.rb:261:in `reload_library'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/rubypython-0.5.1/lib/rubypython.rb:104:in `start'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/pygments.rb-0.1.3/lib/pygments/ffi.rb:8:in `start'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/pygments.rb-0.1.3/lib/pygments/ffi.rb:82:in `highlight'
 from /home/chris/octopress/plugins/pygments_code.rb:24:in `pygments'
 from /home/chris/octopress/plugins/pygments_code.rb:14:in `highlight'
 from /home/chris/octopress/plugins/backtick_code_block.rb:37:in `block in render_code_block'
 from /home/chris/octopress/plugins/backtick_code_block.rb:13:in `gsub'
 from /home/chris/octopress/plugins/backtick_code_block.rb:13:in `render_code_block'
 from /home/chris/octopress/plugins/octopress_filters.rb:12:in `pre_filter'
 from /home/chris/octopress/plugins/octopress_filters.rb:27:in `pre_render'
 from /home/chris/octopress/plugins/post_filters.rb:112:in `block in pre_render'
 from /home/chris/octopress/plugins/post_filters.rb:111:in `each'
 from /home/chris/octopress/plugins/post_filters.rb:111:in `pre_render'
 from /home/chris/octopress/plugins/post_filters.rb:166:in `do_layout'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/jekyll-0.11.0/lib/jekyll/post.rb:189:in `render'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/jekyll-0.11.0/lib/jekyll/site.rb:193:in `block in render'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/jekyll-0.11.0/lib/jekyll/site.rb:192:in `each'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/jekyll-0.11.0/lib/jekyll/site.rb:192:in `render'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/jekyll-0.11.0/lib/jekyll/site.rb:40:in `process'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/gems/jekyll-0.11.0/bin/jekyll:250:in `'
 from /home/chris/.rvm/gems/ruby-1.9.2-p318/bin/jekyll:23:in `load'
from /home/chris/.rvm/gems/ruby-1.9.2-p318/bin/jekyll:23:in `'

Um den Fehler zu beheben ist einfach die Installation des Paketes python-dev unter Debian nötig.

Octopress rake generate lib.so cannot LoadError
Markiert in:        

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.